UK Outbound on International Plans
Incident Report for Hushed
Resolved
This incident has been resolved.
Posted Oct 21, 2022 - 10:19 EDT
Identified
As part of our downstream provider having issues, it's possible customers with UK international plans may be experiencing outbound calling concerns.
Posted Oct 20, 2022 - 11:16 EDT
This incident affected: Outbound Calling.