Degradation of incoming calls

Incident Report for Hushed

Resolved

This incident has been resolved.
Posted Sep 27, 2021 - 20:02 EDT

Monitoring

As part of our downstream provider having issues, its possible customers may not receive incoming calls on an intermittent basis
Posted Sep 27, 2021 - 17:49 EDT
This incident affected: Inbound Calling.