Outgoing calls are not functional
Incident Report for Hushed
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 08:41 EDT
Investigating
We are currently investigating this issue.
Posted Jun 08, 2021 - 08:33 EDT
This incident affected: Outbound Calling.